Suggestions for Function Names & Documentation
Chuck Pelto
cbpelto at pcisys.net
Mon May 8 02:33:36 CDT 2006
Morning Ruslan,
Not sure why you decided to replace GoToRecID() with RecordExists().
They don't mean the same thing in English. The former is titled to
indicate using it will take the user directly to the record he wants
to get to. The latter just means that the record is in there,
somewhere. The latter does not indicate you are being taken to the
record. It's confusing. And, as always, I counsel against confusion
in programming languages/environments. It's enough trouble just
keeping the code going instead of heaping transliterations and other
obfuscations into the heap.
Also, since you DID decide to make this misnomer, may I suggest that
wherever you do such that you put better notes in the documentation
to indicate that there have been significant changes? I spent a bit
of time discovering you'd eliminated the GoToRecID() call, by way of
an obscure note buried in the text of the section, while trying to
update a project started early last year, before the change.
It would also help to indicate deleted/superceded calls in the
heading of each area, e.g., in VTable, something that reads like....
Navigation Methods
FirstRecord() as Boolean
LastRecord() as Boolean
PrevRecord() as Boolean
NextRecord() as Boolean
RecordExists(inRecID as Integer) as Boolean // replaces GoToRecID()
GoToRecID() // OBSOLETE, use RecordExists()
Regards,
Chuck Pelto
More information about the Valentina
mailing list